Nested VLAN на AW

Все что связано с маршрутизирующими коммутаторами и работе с ними

Модератор: Allied Telesis Russia

Nested VLAN на AW

Сообщение smnet » 02 фев 2016, 08:04

Два коммутатора:
AT x900-12XT/S ver 5.4.3-3.17
AT SBx908 (2xXEM-12Sv2 и 1xXEM-12Tv2) ver 5.4.3-3.17

На обоих
Код: Выделить всё
Jumboframe support            on
Vlan-stacking TPID            0x8100


Лицензии x900 Advanced L3 license и SBx908 Advanced L3 license.

На x900 port1.0.2 подключен к клиенту, port1.0.12 - к x908.
Конфиг:
Код: Выделить всё
x900#sh ru int port1.0.2
!
interface port1.0.2
 switchport
 switchport mode access
 switchport access vlan 93
 switchport vlan-stacking customer-edge-port
!
x900#sh ru int port1.0.12
!
interface port1.0.12
 description to spd
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 20,93
 switchport trunk native vlan none
 switchport vlan-stacking provider-port
!
vlan database
 vlan 93 name Test
 vlan 20,93 state enable
!

На x908 port1.6.2 подключен к x900, port1.3.3 - к клиенту.
Конфиг:
Код: Выделить всё
x908#sh ru int port1.6.2
!
interface port1.6.2
 description to_x900
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 20,93
 switchport trunk native vlan none
 switchport vlan-stacking provider-port
!
x908#sh ru int port1.3.3
!
interface port1.3.3
 description Test
 switchport
 switchport mode access
 switchport access vlan 93
 switchport vlan-stacking customer-edge-port
!
vlan database
 vlan 93 name Test
 vlan 20,93 state enable
!

У клиента по краям два коммутатора, 1 vlan управление, на концах не тегирован, 1001 vlan клиенты клиента, затегирован на аплинках.
В приведенной конфигурации коммутаторы клиента друг друга видят, клиенты клиента (1001 vlan) нет.
Быть может, не хватает настроек для VLAN Stacking?
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Re: Nested VLAN на AW

Сообщение Ginodman Mikhail » 02 фев 2016, 12:30

проверьте конечные коммутаторы, при подключении их друг к другу влан 1001 пробрасывается?
какие именно конечные коммутаторы их конфиг?
Ginodman Mikhail
Site Admin
 
Сообщения: 2489
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow

Re: Nested VLAN на AW

Сообщение smnet » 02 фев 2016, 13:11

Ginodman Mikhail писал(а):проверьте конечные коммутаторы, при подключении их друг к другу влан 1001 пробрасывается?
какие именно конечные коммутаторы их конфиг?

Конфиг на обоих аналогичный (естественно, ip разные):
Код: Выделить всё
console# sh ru
interface ethernet g1
switchport mode trunk
exit
vlan database
vlan 1001
exit
interface ethernet e1
switchport access vlan 1001
exit
interface ethernet g1
switchport trunk allowed vlan add 1001
exit
interface vlan 1
ip address 192.168.1.2 255.255.255.0
exit

Напрямую, конечно, все работает.
Более того, простенький Huawei S2318 при настройке 2-х портов в quinq vlan-translation делает все, что нужно на том же стенде.
Но нам необходимо сделать Q-in-Q именно на 908-м.

Забыл написать - на концах 8000S.
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Re: Nested VLAN на AW

Сообщение Ginodman Mikhail » 02 фев 2016, 13:49

перегружали х908, х900?
попробуйте со всех провайдерских портов убрать строчку
switchport vlan-stacking provider-port

если не поможет
нужен с них sh run
Ginodman Mikhail
Site Admin
 
Сообщения: 2489
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow

Re: Nested VLAN на AW

Сообщение smnet » 03 фев 2016, 13:04

Ginodman Mikhail писал(а):перегружали х908, х900?
попробуйте со всех провайдерских портов убрать строчку
switchport vlan-stacking provider-port

если не поможет
нужен с них sh run

Т.к. x908 боевой, пока манипуляции на нем больше проводить не будем, ограничимся x900.
switchport vlan-stacking provider-port убрано. Коммутатор перезагружали.
Теперь сеть доступа клиента подключена к портам 1.0.2 и 1.0.4. По прежнему нетегированный трафик влана 1 ходит, теги 1001 нет.
Конфиг такой (на коммутаторе есть vrf и несколько тестовых vlan для других тестов):
Скрытый текст:
Только для зарегистрированных пользователей.
Скрытый текст:
Код: Выделить всё
!
service password-encryption
!
hostname x900.smnet
!
enable password level 15 8 $1$mc79JXj5tnJm$1zQwdKJIXuhEUsT8juP930
no banner motd
!
username manager privilege 15 password 8 $1$41yd9TPO$cDWxPFb1Ikt0FHQdxMbPaf3ks01
!
access-list standard mcfilter permit 239.255.0.0/18
access-list standard mcfilter permit 224.2.127.254/32
access-list standard newmcf deny 239.255.255.250/32
!
log email admins@smnet
log email admins@smnet level errors
!
ssh server v2only
ssh server session-timeout 3600 login-timeout 30 max-startups 5
ssh server allow-users manager
service ssh ip
!
platform jumboframe
platform routingratio ipv4only
!
no service telnet
!
no service http
!
mail smtpserver 10.10.254.238
!
mail from manager@x900.smnet
!
clock timezone UTC plus 7:00
!
snmp-server
snmp-server location x900
snmp-server enable trap dhcpsnooping
snmp-server source-interface traps vlan701
snmp-server group smnet priv
snmp-server community ccc
snmp-server community ccc
snmp-server user view ccc encrypted auth sha 0x17d12aab40wE8fe226e4b15e9f9a4684cc310c3ebbc0 priv des 0x0e1ec8b2v56a5b07a4125eab5e1f86660bd5dd4039ec
snmp-server host 10.10.10.10 version 2c ccc
snmp-server host 10.10.10.10 version 3 priv view
!
aaa authentication enable default local
aaa authentication login default local
!
ip name-server 10.10.254.251
ip domain-lookup
!
ip dhcp bootp ignore
!
ip dhcp option 121 name static-routes hex
ip dhcp option 249 name static-routes-win hex
!
!
!
service dhcp-server
!
ip vrf subISPnet 2
 description sub-ISP-network
!
ip multicast-routing
!
service dhcp-snooping
ip dhcp snooping agent-option allow-untrusted
!
spanning-tree mode rstp
!
no ipv6 mld snooping
no spanning-tree rstp enable
!
mls qos enable
!
switch 1 provision x900-12
!
vlan database
 vlan 93 name Rb
 vlan 11-12,20,93,700-701,800,1001-1003,2000 state enable
!
interface port1.0.1
 description to subISP gateway
 switchport
 switchport mode access
 switchport access vlan 12
!
interface port1.0.2
 switchport
 switchport mode access
 switchport access vlan 93
 switchport vlan-stacking customer-edge-port
!
interface port1.0.3
 description to SMnet v700-clients
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 700
 ip dhcp snooping max-bindings 520
 ip dhcp snooping violation trap
!
interface port1.0.4
 switchport
 switchport mode access
 switchport access vlan 93
 switchport vlan-stacking customer-edge-port
!
interface port1.0.5
 description to subISP v1001-clients
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 1001-1003
 switchport trunk native vlan 11
 ip dhcp snooping max-bindings 520
 ip dhcp snooping violation trap
!
interface port1.0.6
 switchport
 switchport mode access
 switchport access vlan 701
!
interface port1.0.7
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 800
 switchport trunk native vlan none
!
interface port1.0.8
 switchport
 switchport mode access
 switchport access vlan 800
!
interface port1.0.9
 description to subISP ppp-NAS
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 1001
 switchport trunk native vlan 11
!
interface port1.0.10-1.0.11
 description to subISPbilling
 switchport
 switchport mode access
 switchport access vlan 2000
!
interface port1.0.12
 description to SMnet spd
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 20,700,800
 switchport trunk native vlan none
!
interface vlan1
 description management
 ip address 192.168.251.97/27
!
interface vlan11
 description subISP network devices
 ip vrf forwarding subISPnet
 ip address 192.168.1.1/24
!
interface vlan12
 description subISP-gateway network
 ip vrf forwarding subISPnet
 ip address 192.168.0.2/30
!
interface vlan20
 description from-x900-to-n1
 ip address 192.168.249.46/30
 ip igmp
 ip igmp version 2
 ip pim dense-mode
!
interface vlan700
 description x900testvlan
 ip address 10.9.0.1/24
 ip igmp
 ip igmp access-group newmcf
 ip igmp version 2
 ip pim dense-mode
 ip dhcp snooping
 ip dhcp-relay information policy keep
 ip dhcp-relay server-address 10.10.254.219
!
interface vlan701
 description to Zabbix
 ip address 10.10.10.9/30
!
interface vlan1001
 description sub-ISP-clients
 ip vrf forwarding subISPnet
 ip address 10.16.0.1/24
 ip dhcp snooping
 arp security
 ip dhcp-relay information policy keep
 ip dhcp-relay server-address 10.32.0.2
!
interface vlan1002
 description Juric
 ip vrf forwarding subISPnet
 ip address 10.10.185.1/30
!
interface vlan1003
 description v1003-clients
 ip vrf forwarding subISPnet
 ip address 10.16.1.1/24
 ip dhcp snooping
 arp security
 ip dhcp-relay information policy keep
 ip dhcp-relay server-address 10.32.0.2
!
interface vlan2000
 description to subISPbilling
!
trigger 1
 type periodic 1
 description ping-dhcp-server-from-vlan's-gateways
 script 1 pinger.scp
!
ip route 0.0.0.0/0 192.168.249.45
ip route vrf subISPnet 0.0.0.0/0 192.168.0.1
!
ntp server 192.168.0.1 prefer version 4
ip dns forwarding
!
line con 0
 exec-timeout 0 0
line vty 0 32
 exec-timeout 0 0
!
end
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Re: Nested VLAN на AW

Сообщение Ginodman Mikhail » 03 фев 2016, 13:32

smnet писал(а):
Ginodman Mikhail писал(а):перегружали х908, х900?
попробуйте со всех провайдерских портов убрать строчку
switchport vlan-stacking provider-port

если не поможет
нужен с них sh run

Т.к. x908 боевой, пока манипуляции на нем больше проводить не будем, ограничимся x900.
switchport vlan-stacking provider-port убрано. Коммутатор перезагружали.
Теперь сеть доступа клиента подключена к портам 1.0.2 и 1.0.4. По прежнему нетегированный трафик влана 1 ходит, теги 1001 нет.
Конфиг такой (на коммутаторе есть vrf и несколько тестовых vlan для других тестов):
Скрытый текст:
Только для зарегистрированных пользователей.
Скрытый текст:
Код: Выделить всё
!
service password-encryption
!
hostname x900.smnet
!
enable password level 15 8 $1$mc79JXj5tnJm$1zQwdKJIXuhEUsT8juP930
no banner motd
!
username manager privilege 15 password 8 $1$41yd9TPO$cDWxPFb1Ikt0FHQdxMbPaf3ks01
!
access-list standard mcfilter permit 239.255.0.0/18
access-list standard mcfilter permit 224.2.127.254/32
access-list standard newmcf deny 239.255.255.250/32
!
log email admins@smnet
log email admins@smnet level errors
!
ssh server v2only
ssh server session-timeout 3600 login-timeout 30 max-startups 5
ssh server allow-users manager
service ssh ip
!
platform jumboframe
platform routingratio ipv4only
!
no service telnet
!
no service http
!
mail smtpserver 10.10.254.238
!
mail from manager@x900.smnet
!
clock timezone UTC plus 7:00
!
snmp-server
snmp-server location x900
snmp-server enable trap dhcpsnooping
snmp-server source-interface traps vlan701
snmp-server group smnet priv
snmp-server community ccc
snmp-server community ccc
snmp-server user view ccc encrypted auth sha 0x17d12aab40wE8fe226e4b15e9f9a4684cc310c3ebbc0 priv des 0x0e1ec8b2v56a5b07a4125eab5e1f86660bd5dd4039ec
snmp-server host 10.10.10.10 version 2c ccc
snmp-server host 10.10.10.10 version 3 priv view
!
aaa authentication enable default local
aaa authentication login default local
!
ip name-server 10.10.254.251
ip domain-lookup
!
ip dhcp bootp ignore
!
ip dhcp option 121 name static-routes hex
ip dhcp option 249 name static-routes-win hex
!
!
!
service dhcp-server
!
ip vrf subISPnet 2
 description sub-ISP-network
!
ip multicast-routing
!
service dhcp-snooping
ip dhcp snooping agent-option allow-untrusted
!
spanning-tree mode rstp
!
no ipv6 mld snooping
no spanning-tree rstp enable
!
mls qos enable
!
switch 1 provision x900-12
!
vlan database
 vlan 93 name Rb
 vlan 11-12,20,93,700-701,800,1001-1003,2000 state enable
!
interface port1.0.1
 description to subISP gateway
 switchport
 switchport mode access
 switchport access vlan 12
!
interface port1.0.2
 switchport
 switchport mode access
 switchport access vlan 93
 switchport vlan-stacking customer-edge-port
!
interface port1.0.3
 description to SMnet v700-clients
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 700
 ip dhcp snooping max-bindings 520
 ip dhcp snooping violation trap
!
interface port1.0.4
 switchport
 switchport mode access
 switchport access vlan 93
 switchport vlan-stacking customer-edge-port
!
interface port1.0.5
 description to subISP v1001-clients
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 1001-1003
 switchport trunk native vlan 11
 ip dhcp snooping max-bindings 520
 ip dhcp snooping violation trap
!
interface port1.0.6
 switchport
 switchport mode access
 switchport access vlan 701
!
interface port1.0.7
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 800
 switchport trunk native vlan none
!
interface port1.0.8
 switchport
 switchport mode access
 switchport access vlan 800
!
interface port1.0.9
 description to subISP ppp-NAS
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 1001
 switchport trunk native vlan 11
!
interface port1.0.10-1.0.11
 description to subISPbilling
 switchport
 switchport mode access
 switchport access vlan 2000
!
interface port1.0.12
 description to SMnet spd
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 20,700,800
 switchport trunk native vlan none
!
interface vlan1
 description management
 ip address 192.168.251.97/27
!
interface vlan11
 description subISP network devices
 ip vrf forwarding subISPnet
 ip address 192.168.1.1/24
!
interface vlan12
 description subISP-gateway network
 ip vrf forwarding subISPnet
 ip address 192.168.0.2/30
!
interface vlan20
 description from-x900-to-n1
 ip address 192.168.249.46/30
 ip igmp
 ip igmp version 2
 ip pim dense-mode
!
interface vlan700
 description x900testvlan
 ip address 10.9.0.1/24
 ip igmp
 ip igmp access-group newmcf
 ip igmp version 2
 ip pim dense-mode
 ip dhcp snooping
 ip dhcp-relay information policy keep
 ip dhcp-relay server-address 10.10.254.219
!
interface vlan701
 description to Zabbix
 ip address 10.10.10.9/30
!
interface vlan1001
 description sub-ISP-clients
 ip vrf forwarding subISPnet
 ip address 10.16.0.1/24
 ip dhcp snooping
 arp security
 ip dhcp-relay information policy keep
 ip dhcp-relay server-address 10.32.0.2
!
interface vlan1002
 description Juric
 ip vrf forwarding subISPnet
 ip address 10.10.185.1/30
!
interface vlan1003
 description v1003-clients
 ip vrf forwarding subISPnet
 ip address 10.16.1.1/24
 ip dhcp snooping
 arp security
 ip dhcp-relay information policy keep
 ip dhcp-relay server-address 10.32.0.2
!
interface vlan2000
 description to subISPbilling
!
trigger 1
 type periodic 1
 description ping-dhcp-server-from-vlan's-gateways
 script 1 pinger.scp
!
ip route 0.0.0.0/0 192.168.249.45
ip route vrf subISPnet 0.0.0.0/0 192.168.0.1
!
ntp server 192.168.0.1 prefer version 4
ip dns forwarding
!
line con 0
 exec-timeout 0 0
line vty 0 32
 exec-timeout 0 0
!
end

если на портах клиентов
awplus(config)# interface port1.0.2, port1.0.4
awplus(config-if)# switchport mode access ingress-filter disable

с одним коммутатором вы не проверяете как второй тег 93 добавляется/удаляется
Ginodman Mikhail
Site Admin
 
Сообщения: 2489
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow

Re: Nested VLAN на AW

Сообщение smnet » 03 фев 2016, 14:12

Ginodman Mikhail писал(а):если на портах клиентов
awplus(config)# interface port1.0.2, port1.0.4
awplus(config-if)# switchport mode access ingress-filter disable

с одним коммутатором вы не проверяете как второй тег 93 добавляется/удаляется

Михаил, не совсем Вас понял.
Разве включение двойного тегирования не подразумевает отключения ingress filter?
В данной схеме мне нужен только один коммутатор.
Сейчас по причине необходимости и срочности со стороны клиента стоит коммутатор другого вендора, который заворачивает трафик в 93 влан, передает на x908, тот передает на такой же коммутатор, который убирает второй тег. Вот от этих двух "балластных" коммутаторов я хотел бы избавиться.
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Re: Nested VLAN на AW

Сообщение Ginodman Mikhail » 03 фев 2016, 15:27

Другую прошивку проверяли? Хорошо бы еще зеркалировать порт и посмотреть передаются ли от х908, х900 тегированные кадры в влан 1001 на кастомер портах
Ginodman Mikhail
Site Admin
 
Сообщения: 2489
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow


Вернуться в Коммутаторы 3го уровня

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4

cron