DHCP Relay на x900

Все что связано с маршрутизирующими коммутаторами и работе с ними

Модератор: Allied Telesis Russia

DHCP Relay на x900

Сообщение smnet » 08 июл 2011, 05:51

Здравствуйте!
На тестовом стенде собрана конфигурация, представленная на рисунке.
В качестве коммутатора доступа используется Huawei S2318 с включенным DHCP-snooping. В качестве доверенного назначен один из гигабитных портов, подключенный напрямую в x900 (AlliedWare Plus (TM) 5.4.1). Все, что от него требуется этот "китаец" выполняет (передает DHCP Discover на трастовый порт, вставляет в запрос Opt 82 и т. д.) и на порту 2 x900 DHCP-запросы есть.
Конфигурация x900 выполнялась по мануалу: был глобально включен сервис
Код: Выделить всё
awplus(config)#service dhcp-relay

и в нужный VLAN 150 добавлен адрес сервера
Код: Выделить всё
awplus(config-if)#ip dhcp-relay server-address 192.168.254.2

Код: Выделить всё
awplus#sh ip dhcp-relay

DHCP Relay Service is enabled

vlan150 is up, line protocol is up
Maximum hop count is 10
Maximum DHCP message length is 1400
Insertion of Relay Agent Option is enabled
Checking of Relay Agent Option is disabled
The Remote Id string for Relay Agent Option is 0000cd2ab351
Relay Information policy is to keep DHCP packets as is
List of servers :   192.168.254.2


К порту 8 x900 подключен анализатор трафика и порт настроен для зеркалирования трафика обоих направлений с порта 3.

Естественно, x900 "видит" DHCP-сервер (т.е. для этого создан отдельный VLAN, хотя в дальнейшем планируется иная конфигурация).

Так вот при такой конфигурации на DHCP-сервер запросы не приходят. Подскажите пожалуйста, что не так в настройке или что нужно сделать дополнительно, чтобы коммутатор x900 работал в качестве DHCP Relay.
Спасибо.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Сообщение smnet » 11 июл 2011, 13:23

Быть может, порт DHCP-сервера должен быть в том же VLAN, на котором настроен relay?
Но тогда теряется весь смысл DHCP Relay.
Натолкните на мысль, что не так?
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Сообщение Ginodman Mikhail » 11 июл 2011, 17:05

"нужный" влан 150 это клиентский влан?
Ginodman Mikhail
Site Admin
 
Сообщения: 2519
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow

Сообщение smnet » 12 июл 2011, 06:22

Так точно.
На x900 DHCP-запросы приходят в vlan150.
И в этом vlan сконфигурирован DHCP-Relay.
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Сообщение Ginodman Mikhail » 12 июл 2011, 10:24

sh run ?
Ginodman Mikhail
Site Admin
 
Сообщения: 2519
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow

Сообщение Александр » 12 июл 2011, 10:25

Попробуйте добавить
Код: Выделить всё
awplus(config)# interface vlan150
awplus(config-if)# ip dhcp-relay agent-option checking
Александр
 
Сообщения: 131
Зарегистрирован: 04 апр 2008, 21:57
Откуда: Череповец

Сообщение smnet » 13 июл 2011, 04:56

ip dhcp-relay agent-option checking не помогла.
Вот конфиг:
Код: Выделить всё
hostname.ru#sh ru
!
service password-encryption
!
hostname hostname.ru
!
banner motd welcome to hostname.ru
!
no username manager
!
log email admins@hostname.ru
!
ssh server session-timeout 600 login-timeout 30 max-startups 3
ssh server allow-users root

service ssh ip
!
no service telnet
!
no service http
!
mail smtpserver 10.10.254.238
!
mail from admins@hostname.ru
!
clock timezone UTC plus 8:00
!
no snmp-server ipv6
!
ip name-server 10.10.254.251
ip domain-lookup
!
no service dhcp-server
!
ip multicast-routing
!
spanning-tree mode rstp
!
no ipv6 mld snooping
no spanning-tree rstp enable
!
switch 1 provision x900-12
!
vlan database
 vlan 20 name epsr1-4-5
 vlan 150 name test1
 vlan 151 name test2
 vlan 4094 name Test_DHCP_Relay
 vlan 20,150-151,4094 state enable
!
ip igmp snooping routermode all
!
interface port1.0.1
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 1,20,150-151
 switchport trunk native vlan none
!
interface port1.0.2
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 150-151
!
interface port1.0.3
 switchport
 switchport mode access
 switchport access vlan 4094
!
interface port1.0.4-1.0.7
 switchport
 switchport mode trunk
!
interface port1.0.8
 mirror interface port1.0.3 direction both
 switchport
!
interface port1.0.9-1.0.11
 switchport
 switchport mode trunk
!
interface port1.0.12
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 1,20,150-151
 switchport trunk native vlan none
!
interface vlan1
 ip address 192.168.220.220/27
!
interface vlan150
 ip igmp snooping fast-leave
 ip dhcp-relay agent-option
 ip dhcp-relay agent-option remote-id 0000cd2ab351
 ip dhcp-relay information policy keep
 ip dhcp-relay server-address 192.168.254.2
!
interface vlan151
 ip dhcp-relay information policy keep
 ip dhcp-relay server-address 192.168.254.2
!
interface vlan4094
 description Test for DHCP Relay
 ip address 192.168.254.1/28
!
epsr configuration
 epsr epsr1-4-5 mode transit controlvlan 20
 epsr epsr1-4-5 datavlan 1,150-151
 epsr epsr1-4-5 enhancedrecovery enable
 epsr epsr1-4-5 state enabled
!
ip route 0.0.0.0/0 192.168.220.193
!
ntp peer 10.10.254.254
!
line con 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
!
end
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Сообщение Ginodman Mikhail » 13 июл 2011, 09:23

а если убрать из vlan150

ip dhcp-relay agent-option
ip dhcp-relay agent-option remote-id 0000cd2ab351
ip dhcp-relay information policy keep
?
Ginodman Mikhail
Site Admin
 
Сообщения: 2519
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow

Сообщение smnet » 14 июл 2011, 06:22

Ginodman Mikhail писал(а):а если убрать из vlan150

ip dhcp-relay agent-option
ip dhcp-relay agent-option remote-id 0000cd2ab351
ip dhcp-relay information policy keep
?


К сожалению тоже нет.
А есть ли возможность посмотреть системный журнал или debug-информацию по DHCP-Relay?
Просто вопрос стоит уже больше недели и стоит довольно жестко.
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Сообщение Ginodman Mikhail » 14 июл 2011, 09:40

smnet писал(а):
Ginodman Mikhail писал(а):а если убрать из vlan150

ip dhcp-relay agent-option
ip dhcp-relay agent-option remote-id 0000cd2ab351
ip dhcp-relay information policy keep
?


К сожалению тоже нет.
А есть ли возможность посмотреть системный журнал или debug-информацию по DHCP-Relay?
Просто вопрос стоит уже больше недели и стоит довольно жестко.


необходимо и достаточно команд :

awplus(config)# service dhcp-relay
awplus(config)# int vlan150
awplus(config-if)# ip dhcp-relay server-address 192.168.254.2

для проверки используйте другое устр-во на доступе
также проверьте работу на версии 534-09
Ginodman Mikhail
Site Admin
 
Сообщения: 2519
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow

Сообщение smnet » 15 июл 2011, 05:05

Исключил влияние коммутатора доступа, включив клиента в access-порт x900.
Перенастроил, согласно Вашим рекомендациям, но безрезультатно.
Чувство такое, как будто на x900 работает DHCP-snooping и просто дропает все пакеты (хотя, он, естественно, выключен).
Работу на другой версии AW+ проверить пока не могу.
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Сообщение smnet » 06 апр 2012, 09:41

Вопрос все еще открыт.
DHCP-клиент подключен напрямую в x900.
Код: Выделить всё
interface port1.0.4
 switchport
 switchport mode access
 switchport access vlan 150

Код: Выделить всё
interface vlan150
 ip igmp snooping fast-leave
 ip dhcp-relay information policy keep
 ip dhcp-relay server-address 192.168.250.219

BOOTREQUEST на 4-й порт поступает исправно.
Может x900 не реагирует на broadcast-пакеты на 67-й порт?

К примеру AT-8000S с точно такой же задачей справляется на ура.
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Сообщение Ginodman Mikhail » 06 апр 2012, 14:16

куда сервер подключен?
sh sys
sh run
Ginodman Mikhail
Site Admin
 
Сообщения: 2519
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow

Сообщение smnet » 09 апр 2012, 04:32

Да, в принципе, мало что поменялось.
Код: Выделить всё
n4.smnet.ru#sh ru
!
service password-encryption
!
hostname n4.smnet.ru
!
banner motd welcome to n4.smnet.ru
!
no username manager
!
log email admins@smnet.ru
!
ssh server session-timeout 600 login-timeout 30 max-startups 3
ssh server allow-users root
service ssh ip
!
no service telnet
!
no service http
!
mail smtpserver 10.10.254.238
!
mail from admins@smnet.ru
!
clock timezone UTC plus 8:00
!
no snmp-server ipv6
!
ip name-server 10.10.254.251
ip domain-lookup
!
no service dhcp-server
!
ip multicast-routing
!
service dhcp-snooping
ip dhcp snooping agent-option allow-untrusted
!
spanning-tree mode rstp
!
no ipv6 mld snooping
no spanning-tree rstp enable
!
switch 1 provision x900-12
!
vlan database
 vlan 20 name epsr1-4-5
 vlan 150 name test_stack1
 vlan 151 name test_stack2
 vlan 20,150-151,407-425,493-498,4094 state enable
!
ip igmp snooping routermode all
!
interface port1.0.1
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 1,20,150-151,407-425,493-498
 switchport trunk native vlan none
!
interface port1.0.2
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 150-151,414,497
!
interface port1.0.3
 switchport
 switchport mode trunk
 ip dhcp snooping trust
!
interface port1.0.4
 switchport
 switchport mode access
 switchport access vlan 150
!
interface port1.0.5
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 411-412
!
interface port1.0.6
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 409-410
!
interface port1.0.7
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 415-417,493
!
interface port1.0.8
 mirror interface port1.0.4 direction both
 switchport
!
interface port1.0.9-1.0.11
 switchport
 switchport mode trunk
!
interface port1.0.12
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 1,20,150-151,407-425,493-498
 switchport trunk native vlan none
!
interface vlan1
 ip address 192.168.250.220/27
!
interface vlan150
 ip igmp snooping fast-leave
 ip dhcp snooping
 ip dhcp-relay maxhops 255
 ip dhcp-relay information policy keep
 ip dhcp-relay server-address 192.168.250.219
!
epsr configuration
 epsr epsr1-4-5 mode transit controlvlan 20
 epsr epsr1-4-5 datavlan 1,150-151,407-425,493-498
 epsr epsr1-4-5 enhancedrecovery enable
!
ip route 0.0.0.0/0 192.168.250.193
!
ntp peer 10.10.254.254
!
line con 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
!
end

И версия та же.
Код: Выделить всё
n4.smnet.ru#sh ver

AlliedWare Plus (TM) 5.4.1 07/08/11 11:00:28

Build name : r1-5.4.1-1.5.rel
Build date : Fri Jul 8 11:00:28 NZST 2011
Build type : RELEASE
 NET-SNMP SNMP agent software
 (c) 1996, 1998-2000 The Regents of the University of California.
     All rights reserved;
 (c) 2001-2003, Networks Associates Technology, Inc. All rights reserved;
 (c) 2001-2003, Cambridge Broadband Ltd. All rights reserved;
 (c) 2003, Sun Microsystems, Inc. All rights reserved.
 RSA Data Security, Inc. MD5 Message-Digest Algorithm
 (c) 1991-2, RSA Data Security, Inc. Created 1991. All rights reserved.
 Libedit Library
 (c) 1992, 1993 The Regents of the University of California.
     All rights reserved.
 OpenSSL Library
 Copyright (c) 1998-2008 The OpenSSL Project. All rights reserved.
 Original SSLeay License
 Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com).
 sFlow(R) Agent Software
 Copyright (c) 2002-2006 InMon Corp.
 DHCP Library
 Copyright (c) 2004-2010 by Internet Systems Consortium, Inc;
 Copyright (c) 1995-2003 by Internet Software Consortium.
 Application Interface Specification Framework
 Copyright (c) 2002-2004 MontaVista Software, Inc;
 Copyright (c) 2005-2010 Red Hat, Inc.
 Hardware Platform Interface Library
 Copyright (c) 2003, Intel Corporation;
 Copyright (C) IBM Corp. 2003-2007.
 Corosync Cluster Engine
 Copyright (c) 2002-2004 MontaVista Software, Inc. All rights reserved.
 File Utility Library
 Copyright (c) Ian F. Darwin 1986-1987, 1989-1992, 1994-1995.
 Software written by Ian F. Darwin and others;
 maintained 1994- Christos Zoulas.

Сервер подключен к 3-му порту, клиент к 4-му.
smnet
 
Сообщения: 49
Зарегистрирован: 27 янв 2010, 12:17
Откуда: Дудинка (Таймыр)

Сообщение Ginodman Mikhail » 09 апр 2012, 09:26

если вы проверяете работает ли dhcp relay, то выключите все остальное.

добавьте ip на vlan150 или
как уже писал выше, начиная с пустого конфига сделайте
vlan d
vlan 150

interface port1.0.4
switchport
switchport mode access
switchport access vlan 150

interface vlan1
ip address 192.168.250.220/27
!
interface vlan150
ip dhcp-relay server-address 192.168.250.219
ip address 192.168.1.1/24
Ginodman Mikhail
Site Admin
 
Сообщения: 2519
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow

След.

Вернуться в Коммутаторы 3го уровня

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 5