Относительно большое время отклика между двумя X900 по 10G

Это форум для обсуждения операторского оборудования, такого как iMAP, iMG, NMS

Модератор: Allied Telesis Russia

Относительно большое время отклика между двумя X900 по 10G

Сообщение Konstantin » 25 мар 2009, 17:28

Добрый день.
Схема:
X900_R1 <----10G---->X900_R2

X900-24XS_R1#sh ver
AlliedWare Plus (TM) 5.3.1 02/12/09 10:45:25

Конфиг для обоих свичей одинаков (У R2 int vlan100 - 10.10.10.2):
X900-24XS_R1#sh run
!
service password-encryption
!
log buffered level informational
log console level alerts
log console level errors
!
platform jumboframe
platform enhancedmode qoscounters
!
no snmp-server ipv6
!
no ip domain-lookup
!
no ip multicast-routing
!
spanning-tree mode rstp
no ipv6 mld snooping
!
vlan database
vlan 100 state enable
!
interface port1.1.1
duplex full
switchport
switchport mode trunk
switchport trunk allowed vlan add 100
switchport trunk native vlan none
!
interface vlan100
ip address 10.10.10.1/24
!
line con 0
line vty 0 32
exec-timeout 60 0
!
end

Запускаю:

X900-24XS_R1#ping 10.10.10.2
PING 10.10.10.2 (10.10.10.2) 56(84) bytes of data.
64 bytes from 10.10.10.2: icmp_seq=1 ttl=64 time=3.64 ms
64 bytes from 10.10.10.2: icmp_seq=2 ttl=64 time=2.48 ms
64 bytes from 10.10.10.2: icmp_seq=3 ttl=64 time=2.47 ms
64 bytes from 10.10.10.2: icmp_seq=4 ttl=64 time=2.44 ms
64 bytes from 10.10.10.2: icmp_seq=5 ttl=64 time=2.43 ms

Пробовал и без "platform ..."

Вопрос1:
В связи с чем такие задержки на незагруженном 10G линке между двумя коммутаторами операторского класса "хай-энд" ?

Вопрос2:
Почему при включенном c обеих сторон:
platform jumboframe
и
interface vlan100
mtu 9208
ip address 10.10.10.1/24

Пакеты больше

X900-24XS_R1#ping 10.10.10.2 size 1484
PING 10.10.10.2 (10.10.10.2) 1484(1512) bytes of data.
1492 bytes from 10.10.10.2: icmp_seq=1 ttl=64 time=3.56 ms

не ходят:

X900-24XS_R1#ping 10.10.10.2 size 1500
PING 10.10.10.2 (10.10.10.2) 1500(1528) bytes of data.

?
Konstantin
 
Сообщения: 109
Зарегистрирован: 11 май 2008, 13:34

Сообщение Ginodman Mikhail » 25 мар 2009, 18:23

1
проверять скорость на 10G нужно не менеджмент интерфейсом свича, тут могут мыть любые милисекунды

2
сам свитч не инициирует jumbo frames он их пропускает, те как я понимаю сетевая карта должна быть подключена или другой свитч с включенной опцией jumbo frames
Ginodman Mikhail
Site Admin
 
Сообщения: 2488
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow

Сообщение Konstantin » 26 мар 2009, 09:53

Ginodman Mikhail писал(а):1
проверять скорость на 10G нужно не менеджмент интерфейсом свича, тут могут мыть любые милисекунды


vlan100 - не является менеджмент интерфейсом. Это случайно выбранный инт. L3.
Управление осуществляется через другой влан инт.
Но и это не оправдание такой работы - у нас на сети есть ряд 9924, 8948, так вот при гигабите между ними и под неслабой нагрузкой пакеты между ними (используем как раз таки "менеджмент интерфейсы") ходят по большей части с задержкой не превышающей 1мс.
Может все таки соберете у себя схему и попробуете достигнуть лучших результатов?

2
сам свитч не инициирует jumbo frames он их пропускает, те как я понимаю сетевая карта должна быть подключена или другой свитч с включенной опцией jumbo frames

Вы хотели видимо сказать, что он умеет только коммутировать jumbo frames - ок, проверим, НО почему при включенной опции "platform jumboframe" и указания на влан интерфейсе максимального mtu свич перестает вообще пересылать пакеты больше 1492 байта с этого интерфейса на интерфейс между 2-мя свичами даже без флага "не фрагментировать" ?
Konstantin
 
Сообщения: 109
Зарегистрирован: 11 май 2008, 13:34

Сообщение S.Bat » 27 мар 2009, 15:32

Код: Выделить всё
 jumbo frames

вообще ведет себя не понятно на этом девайсе. :x
может перестать работать вообще все.
:idea: Сделали бы как в 98хх - только на конкретных портах выставлять.
S.Bat
 
Сообщения: 56
Зарегистрирован: 09 апр 2008, 13:28
Откуда: Краснодар

Сообщение Konstantin » 27 мар 2009, 16:35

S.Bat писал(а):
Код: Выделить всё
 jumbo frames

вообще ведет себя не понятно на этом девайсе. :x
может перестать работать вообще все.
:idea: Сделали бы как в 98хх - только на конкретных портах выставлять.


Можно узнать с какой задержкой бегают пакеты между вашими X90X девайсами ?
Konstantin
 
Сообщения: 109
Зарегистрирован: 11 май 2008, 13:34

Сообщение Александр » 27 мар 2009, 17:58

Меня после 9924 тоже смутила скорость ответа на ping в x900, однако это не сервер, а коммутатор, а коммутирует он вполне прилично.

Вот пинг до свича x900
PING 192.0.252.242 (192.0.252.242) 56(84) bytes of data.
64 bytes from 192.0.252.242: icmp_seq=1 ttl=61 time=2.51 ms
64 bytes from 192.0.252.242: icmp_seq=2 ttl=61 time=2.31 ms
64 bytes from 192.0.252.242: icmp_seq=3 ttl=61 time=2.34 ms
64 bytes from 192.0.252.242: icmp_seq=4 ttl=61 time=2.37 ms

А вот ping до другого свича к которому пакеты летят через хоп на том же х900
PING 10.10.0.241 (10.10.0.241) 56(84) bytes of data.
64 bytes from 10.10.0.241: icmp_seq=1 ttl=59 time=1.91 ms
64 bytes from 10.10.0.241: icmp_seq=2 ttl=59 time=1.47 ms
64 bytes from 10.10.0.241: icmp_seq=3 ttl=59 time=1.47 ms

Вывод: не в скорости ответа на ping счастье
Александр
 
Сообщения: 131
Зарегистрирован: 04 апр 2008, 21:57
Откуда: Череповец

Сообщение Konstantin » 28 мар 2009, 12:35

Александр писал(а):Меня после 9924 тоже смутила скорость ответа на ping в x900, однако это не сервер, а коммутатор, а коммутирует он вполне прилично.

это как минимум L3 коммутатор, т.о. он обязан высококачественно коммутировать и L3.

Вот пинг до свича x900
PING 192.0.252.242 (192.0.252.242) 56(84) bytes of data.
64 bytes from 192.0.252.242: icmp_seq=1 ttl=61 time=2.51 ms
64 bytes from 192.0.252.242: icmp_seq=2 ttl=61 time=2.31 ms
64 bytes from 192.0.252.242: icmp_seq=3 ttl=61 time=2.34 ms
64 bytes from 192.0.252.242: icmp_seq=4 ttl=61 time=2.37 ms

один к одному.

А вот ping до другого свича к которому пакеты летят через хоп на том же х900
PING 10.10.0.241 (10.10.0.241) 56(84) bytes of data.
64 bytes from 10.10.0.241: icmp_seq=1 ttl=59 time=1.91 ms
64 bytes from 10.10.0.241: icmp_seq=2 ttl=59 time=1.47 ms
64 bytes from 10.10.0.241: icmp_seq=3 ttl=59 time=1.47 ms

я правильно понимаю, что в данном случае x900 - "маршрутизирует" пакеты до другого коммутатора и при этом время ответа ниже, чем если бы он сам отвечал на запросы ?

Вывод: не в скорости ответа на ping счастье

полностью согласен, но где гарантия, что фреймы/пакеты с другими протоколами коммутируются/маршрутизируются как минимум не медленней ?
Konstantin
 
Сообщения: 109
Зарегистрирован: 11 май 2008, 13:34

Сообщение Александр » 29 мар 2009, 13:30

Да именно так x900 - "маршрутизирует" пакеты до другого коммутатора и при этом время ответа ниже, чем если бы он сам отвечал на запросы.
Александр
 
Сообщения: 131
Зарегистрирован: 04 апр 2008, 21:57
Откуда: Череповец

Сообщение Konstantin » 31 мар 2009, 11:41

Александр писал(а):Да именно так x900 - "маршрутизирует" пакеты до другого коммутатора и при этом время ответа ниже, чем если бы он сам отвечал на запросы.


возможно тех. поддержка объяснила бы в связи с чем такое поведение, ведь, например, на 9924 я такого не наблюдаю.
Konstantin
 
Сообщения: 109
Зарегистрирован: 11 май 2008, 13:34

Сообщение Ginodman Mikhail » 31 мар 2009, 12:50

разные OC разные времена отклика, основная задача любого свича коммутировать L2/L3 на скорости порта, менеджмент процессы (SNMP, STP, Telnet, DHCP, ping и тд) терпимы к временным задержкам. проверяйте конечными устр-ми а не пингами с коммутаторов
Ginodman Mikhail
Site Admin
 
Сообщения: 2488
Зарегистрирован: 29 янв 2008, 14:32
Откуда: AlliedTelesis Moscow


Вернуться в Операторское оборудование

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1